Tuesday, December 13, 2011

Chimera 1.7.0 Change Log

Back ported the following Chameleon commits:
  • r1671 Updated credits
  • r1674 Improved Multi-drive boot support from dmazar.
  • r1710 Fix for kernel flags not being passed to kernel on RAID volumes.
Added the following AMD GPUs:
  • 0x9440, 0x114A174B, CHIP_FAMILY_RV770, "Sapphire Radeon HD4870 Vapor-X", kCardinal
  • 0x954F, 0x20081787, CHIP_FAMILY_RV710, "ATI Radeon HD 4350", kNull
  • 0x6899, 0xE174174B, CHIP_FAMILY_CYPRESS, "ATI Radeon HD 5850", kUakari
  • 0x68A0, 0x043A1028, CHIP_FAMILY_CYPRESS, "ATI Mobility Radeon HD 5870", kNomascus
  • 0x68B8, 0x21F61458, CHIP_FAMILY_JUNIPER, "ATI Radeon HD 5770", kVervet
  • 0x68B8, 0x200A1787, CHIP_FAMILY_JUNIPER, "ATI Radeon HD 5770", kVervet
  • 0x68BE, 0x22881787, CHIP_FAMILY_JUNIPER, "ATI Radeon HD 5750", kVervet
  • 0x68F9, 0x010E1002, CHIP_FAMILY_CEDAR, "ATI Radeon HD 5450", kEulemur
  • 0x68F9, 0x03741043, CHIP_FAMILY_CEDAR, "ATI Radeon HD 5450", kEulemur
  • 0x68F9, 0x23401462, CHIP_FAMILY_CEDAR, "ATI Radeon HD 5450", kEulemur
  • 0x68F9, 0xE145174B, CHIP_FAMILY_CEDAR, "ATI Radeon HD 5450", kEulemur
  • 0x68F9, 0xE153174B, CHIP_FAMILY_CEDAR, "ATI Radeon HD 5450", kEulemur
  • 0x6719, 0x0B001002, CHIP_FAMILY_CAYMAN, "AMD Radeon HD 6950", kGibba
  • 0x6719, 0x20101787, CHIP_FAMILY_CAYMAN, "AMD Radeon HD 6950", kGibba
  • 0x6720, 0x04BA1028, CHIP_FAMILY_BARTS, "AMD Radeon HD 6970M", kElodea
  • 0x6738, 0x31071682, CHIP_FAMILY_BARTS, "AMD Radeon HD 6870", kDuckweed
  • 0x6738, 0x31081682, CHIP_FAMILY_BARTS, "AMD Radeon HD 6870", kDuckweed
  • 0x6738, 0x174B174B, CHIP_FAMILY_BARTS, "AMD Radeon HD 6870", kBulrushes
  • 0x6739, 0xAA881002, CHIP_FAMILY_BARTS, "AMD Radeon HD 6850", kDuckweed
  • 0x6740, 0x1D121043, CHIP_FAMILY_TURKS, "AMD Radeon HD 6730M", kNull
  • 0x6760, 0x165A103C, CHIP_FAMILY_CAICOS, "AMD Radeon HD 6470M", kNull
  • 0x6760, 0x167D103C, CHIP_FAMILY_CAICOS, "AMD Radeon HD 6470M", kNull
  • 0x68A0, 0x00000000, CHIP_FAMILY_CYPRESS, "ATI Radeon HD 5800M Series", kNomascus
  • 0x68BA, 0x00000000, CHIP_FAMILY_JUNIPER, "ATI Radeon HD 6770 Series", kVervet
  • 0x6719, 0x00000000, CHIP_FAMILY_CAYMAN, "AMD Radeon HD 6950 Series", kGibbas
Added a change that should hopefully allow the ability to override kNull frame buffer definitions.

Added the following NVIDIA GPUs:
  • 0x10DE06DF, "Tesla M2070-Q" 
  • 0x10DE0DCD, "GeForce GT 555M" 
  • 0x10DE0DCE, "GeForce GT 555M" 
  • 0x10DE0DD6, "GeForce GT 550M" 
  • 0x10DE0DDA, "Quadro 2000M" 
  • 0x10DE0DEC, "GeForce GT 525M" 
  • 0x10DE0DED, "GeForce GT 520M" 
  • 0x10DE0DF4, "GeForce GT 450M" 
  • 0x10DE0DF5, "GeForce GT 525M" 
  • 0x10DE0DF6, "GeForce GT 550M" 
  • 0x10DE0DF7, "GeForce GT 520M" 
  • 0x10DE0DFA, "Quadro 1000M" 
  • 0x10DE0E31, "GeForce GTX 485M" 
  • 0x10DE0E3A, "Quadro 3000M" 
  • 0x10DE0E3B, "Quadro 4000M" 
  • 0x10DE1054, "GeForce GT 410M" 
  • 0x10DE1057, "Quadro NVS 4200M" 
  • 0x10DE107F, "NVIDIA GF119-ES" 
  • 0x10DE10C5, "GeForce 405" 
  • 0x10DE1201, "GeForce GTX 560" 
  • 0x10DE1251, "GeForce GTX 560M"
Added the following cards to the NVIDIA memory detection bug workaround:
  • GT 440 Device ID 0x0DE0 
  • GT 525M Device ID 0x0DEC
There is a standalone installer, available at tonymacx86.com/downloads. For bug reporting, feature requests, and general feedback please use the Chimera forum.

-MacMan tonymacx86  
For discussions on this and other topics, register today at tonymacx86.com!

21 comments:

Anonymous said...

so 6950's are supported now? what about 6970's or the 6990?

Flym4n said...

It's cool that you kee maintaining it, I was about to switch to trunk :)
Thanks

joshua said...

no luck for XFX HD 4350 :(

MacManx86 said...

When a card is supported in Chimera it only means that the boot loader can identify and configure it. It does not mean that it will work OOB.

joshua said...

i agree , when i try with -v i get this com.apple.user event agent .iogin window 93 job has not died after being cleanly killed 2 second ago . simulating exit . what error can you pls explain thank you :)

idany said...

finaly work radeon hd6770 thanks friend

Anonymous said...

Hello Tony!
I wanted to know if you've officially given up the intention to operate the IntelHDGraphics Arrandale, We all we care so much to this, I beg you on behalf of all, give us some news and let us know your intentions!
greetings from Italy

Anonymous said...

Er... will the bootloader be included in the UniBeast USB install method? Because using Chimera from my main drive causes a kp. My Unibeast drive is a partition on my main drive, and it uses an older version of chimera. that is how i boot my lion partition. so pls update for unibeast as well!

hoony91 said...

so does this mean i can build a hackintosh now with my 6950?

Anonymous said...

why no support for geforce 540M too?

MacManx86 said...

@ Anonymous

UniBeast is working as intended and doesn't need any of these new features to install OS X or be used as a rescue boot drive.

Using UniBeast on a hard drive partition for booting is unsupported and not recommended.

MacManx86 said...

@ Anonymous

I can only add support for devices I have device info for, so that is why the GeForce 540M is not supported.

tonymacx86 said...

@ Anonymous
We have given up on 1st gen Intel HD graphics. Even if enabled- you won't get very good performance- best to get a discreet graphics card for Socket 1156 i3 systems.

Anonymous said...

Uh.. how about gtx 570?

Anonymous said...

ati radeon 5850 mobility does it work?

SRSR333 said...

The GeForce Gt 525M graphics seems to have been enabled. Does that mean Lion on my laptop with Optimus will start to use that? Because I only have the HD 3000 (athough it works well, with full qe/ci and acceleration. Portal 2 runs at 45 fps at medium settings, full screen 1366x768 resolution.) But i really would like the Nvidia graphics to be recognised.

Fgt said...

Hi! Wt about supports for GTX 460M? i'm getting crazy with the freeze panes

tks

Anonymous said...

hay...what about ati hd 6670?? does it work

Anonymous said...

hey nvidia gt 525 is now recognized but vram is 0mb pls do something

Anonymous said...

6670 Please

Anonymous said...

Hey, macman. If possible, could you add the 550 Ti to the memory detection bug workaround? I have an EVGA GeForce 550 Ti 2048 MB and it's being detected as 3072 MB.

Post a Comment